Your cart

Timer.

empty cart

Your cart currently empty.

Shop now

You may also be interested in:

  • UV Dynamics 400152 Replacement UV Lamp
    UV Dynamics 8.40 UV Lamp #400152 Free Shipping
    Sold out
    Regular price
    Sale price
    Regular price
    Unit price
    per 
  • Pentek 10" BB Sediment DGD-5005 #155357-43 Free Ship
    Pentek 10
    Sold out
    Regular price
    $ 88.00 CAD
    Sale price
    $ 88.00 CAD
    Regular price
    $ 110.00 CAD
    Unit price
    per 
FREE Water Test Evaluation|Price Match GUARANTEE

Free Shipping in Canada for ALL Products! Learn more

How to Test the Flow Sensor in Aquamaster or Water Boss Water Softener

Article Image

Summary

Whenever water flows through an Aquamaster Water Softener, you will see the gallon per minute flow rate displayed on the controller.  If nothing is being displayed on the controller follow this advice to trouble shoot.

 

 

Whenever water flows through an Aquamaster Water Softener, you will see the gallon per minute flow rate displayed on the controller.  If nothing is being displayed on the controller when treated water is running in the house you can trouble shoot by testing the sensor.  Please note that if the water softener was plumbed backwards it would also not register flow, so check that first. 

1)  Remove the valve cover and remove the sensor from the Bypass housing.

2) Test with a magnet on either flat side of sensor. If flow is indicated, then the sensor is working and you will need to check the turbine.

3) If no flow is indicated in the magnet test, replace the sensor, if still no flow is indicated after replacing the sensor, replace the circuit board.

How to Remove a Salt Clog from an Aquamaster or Water Boss Water Softener

Leave a Comment

Comments must be approved before appearing

Your Name *
Email *
Message

Sign up for my newsletter